Partagez
Voir le sujet précédentAller en basVoir le sujet suivant
mystik
Messages : 16
Réputation : 1
Date d'inscription : 29/08/2012

pb gps naza

le Mer 12 Sep - 19:21
voila mon problème,depuis que j 'ai le gps naza de monté mon quad ne réagit plus comme avant...Je pense avoir tout régler correctement ,mais a chaque fois que j enclenche le gps mon quad part tout seul en avant,quasiment instantanément quand je passe en mode gps....Je ne comprends pas ,j ai tenté de recalibrer les manches ,le compas (magnétique),changer les valeurs (x,y,z pour la position du gps) et depuis ce matin ,j 'ai créé un nouveau programme sur ma radio pour être certain que je n avais pas de mix qui trainait a droite ou a gauche ...eh ben c pareil....
je ne vois plus quoi faire!! Je précise que je décolle en atti j attends d avoir la lumière verte unique et après je test le mode gps....
j'ai oublié de préciser que mon mode atti est stable mais que des que je passe en mode gps ,il s incline vers l avant en général et part tout seul....J ai même diminué mes gains a 100 qui sont très élevés(180) d habitude en pensant que ça pouvait être ça,mais non...

J ai la flèche et le fils du gps vers l avant.;-) et j 'ai bien le nouvelle assistant 1.8 avec le firmware 2.02

alors après un après midi de test avec un copain , le résultat n 'est pas des plus réjouissant pour moi...On a testé son antenne gps sur mon quad ,il se barre quasi dans la foulé ayant activé le gps...et mon antenne gps a l air de fonctionner parfaitement sur le sien...
J'ai des eu des pertes de contrôle que j avais déjà eu mais moins importante et j avais pu les reprendre sans trop de pb,la une grosse perte de contrôle et plus moyen de le contrôler après mon passage en atti qui me l a mis au sol ,mais sans dégâts ,il s est juste pris pour un avion en train d atterrir...Je l avais bien descendu avant heureusement .
Je vais test un second naza pour voir ce que ça donne...si c'est le naza qui foire!!!

Bon,changement de naza effectué,le problème reste le même j'ai déjà enlevé le tx vidéo et la caméra pour voir le changement!!!,pas mieux,donc pas le naza....

Je viens de faire le test avec un mat de fortune(tige en bois diam 5 de 17cm de long,trop souple),Mais bon,ça ne change pas grand chose...j'ai fait le test avec les 2 naza,des que j enclenche le gps,il part....J'ai quand même l'impression que le mode atti avec le gps de branché réagit mieux avec ce mat,il ne fait plus de lacet seul et m'a l 'air assez stable....contrairement a avant.Sinon ,je ne vois plus rien...
Il n y a que la radiocommande et le récepteur(neuf) que j'ai pas test...J'ai refait un nouveau modèle pour être certain de ne rien avoir comme mix ou erreur possible...
Avez vous deja entendu parler de dysfonctionnement de radio qui envoi des ordres au récepteur quand on active un potard???sur mon ancien modèle,j'avais remarqué 1 bouton qui le faisait(bouton sur 1---> 1 ou 2 crans sur l axe E),bouton que j'ai bien entendu désactivé par la suite...
Si vous avez une autre idée,je ne vois plus ce que je peux faire
avatar
Black-Raiser
Admin
Messages : 1916
Réputation : 72
Date d'inscription : 14/01/2010
Age : 39
Localisation : Ceyzériat
http://www.kilowattrc.com

Re: pb gps naza

le Mer 12 Sep - 19:58
Salut d abord tu as quelle radio ?

sinon tu ne fais pas une bonne mise en route
la led verte c est le mode GPS
la led orange c est le mode ATTI
et quand sa clignote tres vite en orange rouge , c est le mode failsafe

rien qu avec sa je suppose que le pb vienne de ta radio
le reglage de ton inter 3 position doit etre mal configuré

voici la procedure pour la mise en route:
pose ton drone au sol
allume ta radio et mets toi en mode atti ou GPS
fixe l accu sur le drone
connect les cosses , la faut surtout pas bouger le drone , le NAZA a besoin de 3 secondes pour s initialiser
apres avoir attendu 4-5 secondes connect ton fpv , installe toi et observe la led
au demarage tu dois attendre que le gps capte 7 satelites ou plus
en observant la led , si tu est en mode ATTI donc clignotement orange avec 1;2ou3 flash rouge , cela indique le nb de satelites connecté sur le gps
3 flash rouge signifie que le gps capte moins de 5 satelites
2 flash rouge c est pour 5 satelites
1 flash rouge c est 6 satelites
zero flash rouge c est plus de 6 satelite
donc faut attendre 2 minutes environ
une fois le GPS opé donc plus de flash rouge , tu peux decoller , quand tu poussera les gaz pour decoller , le GPS cré le point home , il lui faut minimum 6 satelites pour le creer

voila , t as pu qu a regler ta radio sur l inter ATTI/GPS
je te deconseil le mode normale , en FPV c est chaud et en vol a vue faut pas etre debutant (pas de stabilisation)
regle l inter de ta radio sur GPS-ATTI-Failsafe
donc l inter au milieu pour ATTI , en avant pour GPS et vers toi pour failsafe

ton drone reviendra tout seul a son point de depart ( a condition d avoir activé le RTH sur l interface)
Jul.
mystik
Messages : 16
Réputation : 1
Date d'inscription : 29/08/2012

Re: pb gps naza

le Mer 12 Sep - 20:39
J'ai une dx7s de spektrum...
l’interrupteur 3 positions est bien réglé sur gps,atti et manu(pour que chacun passe au bleu suivant la position du bouton).pour le moment,je laisse comme ça pour le calibrage,tant qu il ne fonctionne pas correctement.SInon la procédure de démarrage est la même que je fais actuellement,sauf le fpv(je l'ai enlevé pour les tests).Sinon,je ne test plus de décollage tant qu'il y a une lumière rouge et j'ai vu que certain décollé en atti pour diminuer les pbs.
avatar
Black-Raiser
Admin
Messages : 1916
Réputation : 72
Date d'inscription : 14/01/2010
Age : 39
Localisation : Ceyzériat
http://www.kilowattrc.com

Re: pb gps naza

le Mer 12 Sep - 20:46
perso je ne vole le 450 qu en FPV , au decolage GPS et no problemes
as tu réinstallé le firmware et tout recalibré ?

conseil mets failsafe plutot que normal et active le RTH dans l interface , tu tire l inter ton drone reviens et programme bien le failsafe du recepteur que si tu perds le signal radio , ton drone reviens

vu les test que t as fait tout fonctionne donc tu dois avoir mal fait une etape , reprends tout a zero
mystik
Messages : 16
Réputation : 1
Date d'inscription : 29/08/2012

Re: pb gps naza

le Mer 12 Sep - 21:02
j'ai bien le naza assist 1.8 et firmware 2.02...J'ai calibré les sticks ,fait une calibration imu,retest avec différent gains,différentes positions pour l emplacement du gps(plus ou moins précise).Je n'ai pas activé le failsafe parceque je fais mes réglages dans le jardin et qu il y a juste des arbres et un toit autour de mon point de décollage ;-) donc ,landing direct si problème qu il n'a jamais fait encore...

Je pense que tu n 'as pas compris mon problème,le quad part comme s il avait "une position de fail safe" je ne sais ou et si je le contre pas ,fail safe ou pas il se barre... et plus je le laisse partir plus j'ai du mal a le reprendre en atti(il met du temps pour réagir et ne respecte pas tout a fait les commandes ).Donc ,si je dois voler et le contrer constamment ,tu imagines l interet du gps ;-)
avatar
Black-Raiser
Admin
Messages : 1916
Réputation : 72
Date d'inscription : 14/01/2010
Age : 39
Localisation : Ceyzériat
http://www.kilowattrc.com

Re: pb gps naza

le Mer 12 Sep - 21:06
réinstale le firmware...
fais meme un essai avec le 2.01
mystik
Messages : 16
Réputation : 1
Date d'inscription : 29/08/2012

Re: pb gps naza

le Mer 12 Sep - 21:20
Je l'ai deja fait quand tu m avais dis de mettre a jour le firmware,j’étais déjà a jour et pour être certain que la maj a bien fonctionné ,je suis revenu au 2.01 refait des test et repassé sur le 2.02 après...
Je n'ai rien a perdre je referais ca demain matin si ca va et je te tiens au courant...
mystik
Messages : 16
Réputation : 1
Date d'inscription : 29/08/2012

Re: pb gps naza

le Ven 14 Sep - 10:35
restauration du 2.01,réglage stick et verif de la position du bouton mode de vol...RAS . C'est normal qui ne me demande pas de remettre les valeurs de gains ,il me semble que tu m 'avais dit que cela revenait a zéro???
TEST en vol ,le gps trouve ses satellites dans les 10 sec(lumière verte clignotante),je décolle en atti ,le stabilise a 2 mètres du sol en atti.RAS Je branche le gps et il se laisse emporté par la petite brise qu il y a...
Je vais repasser en 2.02 et refaire le test en vol.
Contenu sponsorisé

Re: pb gps naza

Voir le sujet précédentRevenir en hautVoir le sujet suivant
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum